Probleme mit PXE Boot nach Migration von Cisco Catalyst 65xx zu Nexus 7k

Nach der Migration von einem Cisco Catalyst 65xx zu einem Nexus 7k hat der PXE Boot von VM Maschinen nicht mehr funktioniert. Auf dem L3 Interface war ein IP Helper konfiguriert.

Das neue L3 Interface am Nexus ist wie folgt konfiguriert:

interface Vlan123
  description VM
  no shutdown
  vrf member VM
  no ip redirects
  ip address 10.123.123.252/24
  no ipv6 redirects
  hsrp version 2
  hsrp 123
    authentication md5 key-string MySuperSecret
    preempt delay minimum 90
    priority 255
    timers 1 3
    ip 10.123.123.254
  ip dhcp relay address 10.201.201.1 # dhcp server
  ip dhcp relay address 10.201.201.2 # dhcp server

Folgende Options sind auf dem DHCP für das Netz 10.123.123.0/24 konfiguriert:

option 66 10.200.200.250,10.200.200.251 # tftp-server

option 67 boot.bin # boot-file

Folgende Meldungen erscheinen beim booten der VM:

iPXE 1.0.0+ -- Open Source Network Boot Firmware -- http://ipxe.org
Features: iSCSI HTTP DNS TFTP AoE bzImage ELF MBOOT PXE Menu PXEXT

net0: c0:ff:ee:c0:ff:ee using rtl8139 on PCI00:04.0 (open)
    [Link|up, TX:0 TXE:0 RX:0 RXE:0]
DHCP (net0 c0:ff:ee:c0:ff:ee)...... ok
net0: 10.123.123.10/255.255.255.0 gw 10.123.123.254
Filename: boot.bin
Could not start download: Operation not supported (http://ipxe.org/3c092003)
No more network devices


No bootable device
Powering off in 30 seconds.

Folgender Cisco Community Eintrag hat zur Lösung geführt:

Nexus 7000 & PXE Boot – Cisco Community

Because the Nexus 7000 does NOT broadcast these DHCP broadcast packets to all ports within the VLAN I added the image server as a relay-agent and bingo PXE Boot started working again.

muca – Nexus 7000 & PXE Boot – Cisco Community

Ich habe die TFTP Server jetzt als DHCP Relays mit eingetragen und der PXE Boot funktioniert 🙂

interface Vlan123
  description VM
  no shutdown
  vrf member VM
  no ip redirects
  ip address 10.123.123.252/24
  no ipv6 redirects
  hsrp version 2
  hsrp 123
    authentication md5 key-string MySuperSecret
    preempt delay minimum 90
    priority 255
    timers 1 3
    ip 10.123.123.254
  ip dhcp relay address 10.201.201.1 # dhcp server
  ip dhcp relay address 10.201.201.2 # dhcp server
  ip dhcp relay address 10.200.200.250 # tftp server
  ip dhcp relay address 10.200.200.251 # tftp server

Weitere Details zu den Unterschieden Cisco Catalyst 65xx ip helper vs. Cisco Nexus ip dhcp relay:

Differences between DHCP relay on the Nexus7000/NXOS and IP Helper on the 6500/IoS – Cisco Community

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.

Diese Website verwendet Akismet, um Spam zu reduzieren. Erfahre mehr darüber, wie deine Kommentardaten verarbeitet werden.